Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        MMS Delivery Delay To T-Mobile USA using subset of longcodes

        Incident Report for Twilio

        Resolved

        We are no longer experiencing MMS delivery delays when sending messages to T-Mobile USA using subset of longcodes. This incident has been resolved.
        Posted May 25, 2023 - 11:34 PDT

        Update

        We continue to observe recovery of MMS Delivery Delays To T-Mobile USA using a subset of longcodes. We are monitoring the service to ensure a full recovery, and we will provide another update in 2 hours or as soon as more information becomes available.
        Posted May 25, 2023 - 09:38 PDT

        Update

        We continue to observe recovery of MMS Delivery Delays To T-Mobile USA using a subset of longcodes. We are monitoring the service to ensure a full recovery, and we will provide another update in 2 hours or as soon as more information becomes available.
        Posted May 25, 2023 - 07:41 PDT

        Monitoring

        We have observed a recovery from the MMS Delivery Delay To T-Mobile USA using subset of longcodes. We are monitoring the service to ensure a full recovery, and we will provide another update in 2 hours or as soon as more information becomes available.
        Posted May 25, 2023 - 05:45 PDT

        Update

        We are continuing to experience MMS Delivery Delay To T-Mobile USA using subset of longcodes . Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
        Posted May 25, 2023 - 04:07 PDT

        Investigating

        We are experiencing MMS Delivery Delay To T-Mobile USA using subset of longcodes . Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
        Posted May 25, 2023 - 03:08 PDT
        This incident affected: CARRIER NETWORK (MMS Long Code, North America).