Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delays in international outbound SMS delivery
Incident Report for Twilio
Resolved
This incident has been resolved. All delayed messages have been delivered and new messages are being delivered without delay.
Posted 3 months ago. Nov 15, 2018 - 01:36 PST
Investigating
We are investigaing intermittant delays in outbound SMS delivery
Posted 3 months ago. Nov 15, 2018 - 00:11 PST
This incident affected: PROGRAMMABLE MESSAGING (SMS).