Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delivery Reports Failures on US Long Codes to Sprint Handsets
Incident Report for Twilio
Resolved
The missing delivery report issue which affected SMS from US long codes to Sprint handsets is now resolved.
Posted 12 days ago. Mar 11, 2019 - 23:34 PDT
Monitoring
We are observing recovery on delivery reports of SMS from US long codes to Sprint handsets. Our engineering team will continue to monitor the service
Posted 12 days ago. Mar 11, 2019 - 22:36 PDT
Update
We are continuing to investigate this issue.
Posted 12 days ago. Mar 11, 2019 - 18:06 PDT
Update
We are continuing to investigate this issue.
Posted 12 days ago. Mar 11, 2019 - 18:05 PDT
Update
We are continuing to work with our carrier partners to resolve the ongoing issue with delivery reports on long code messages towards Sprint handsets
Posted 13 days ago. Mar 11, 2019 - 17:27 PDT
Investigating
We are currently observing missing delivery reports (DLRs) of SMS messages from US Long Codes to Sprint handsets. Message delivery is not affected. We are working with our carrier partner to resolve the issue. We will provide an update as soon as possible
Posted 13 days ago. Mar 11, 2019 - 14:24 PDT
This incident affected: CARRIER NETWORK (SMS Long Code, North America) and PROGRAMMABLE MESSAGING (SMS).