Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Console and API Billing Delays
Incident Report for Twilio
Resolved
We are no longer experiencing delays with billing information retrieval and updates in the Twilio console and API. This incident has been resolved.
Posted Jan 13, 2021 - 12:18 PST
Update
We are seeing recovery with the Pricing API. Our engineers will continue to monitor for system stability. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Jan 13, 2021 - 11:12 PST
Update
We are seeing recovery with the Pricing API. Our engineers will continue to monitor for system stability. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Jan 13, 2021 - 10:12 PST
Monitoring
We are seeing recovery with the Pricing API. Our engineers will continue to monitor for system stability. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Jan 13, 2021 - 09:42 PST
Investigating
We are currently experiencing delays with billing information retrieval and updates in the Twilio console and API. Any customers attempting to retrieve or update billing data in the Console or via the API for all products will experience delays. Our engineering team is currently investigating. We will have another update in 30 minutes or as soon as new information is available.
Posted Jan 13, 2021 - 09:07 PST
Monitoring
Our monitoring systems detected an issue with the Pricing API. Our engineering team resolved the issue and requests for billing data are no longer delayed. Our engineering team will continue to actively monitor. We will provide another update in 30 minutes or as soon as we have more information.
Posted Jan 13, 2021 - 08:14 PST
Investigating
Our monitoring systems have detected a potential issue with Pricing API. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jan 13, 2021 - 07:47 PST
This incident affected: TWILIO PLATFORM (Billing, Console, REST API).