Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Verizon SMS Duplicate Delivery in OH and IN
Incident Report for Twilio
Resolved
Delivery issues have not reoccured in over 24 hours and the service is operating normally.
Posted 13 days ago. Mar 10, 2019 - 20:18 PDT
Monitoring
We are unable to reproduce this issue and have not received any reports of it's occurrence in the past several hours. We will continue to monitor until our carrier partner can confirm it has been resolved and update status as we have more information.
Posted 15 days ago. Mar 09, 2019 - 14:17 PST
Update
We are continuing to investigate this situation and working with our carrier partner to resolve it.
Posted 15 days ago. Mar 09, 2019 - 01:54 PST
Investigating
We are observing a subset of Verizon customers in the Indiana and Ohio areas receiving duplicate SMS messages. Our carrier partner is aware and investigating the cause.
Posted 16 days ago. Mar 08, 2019 - 11:41 PST
This incident affected: CARRIER NETWORK (SMS Long Code, North America).