Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Devices Using Super SIM May Experience Delays In Connecting
Incident Report for Twilio
Resolved
Devices using Super SIMs are successfully connecting to networks and establishing data sessions. This incident is resolved.
Posted Sep 18, 2020 - 14:28 PDT
Monitoring
We are again seeing devices using Super SIMs successfully connecting to networks and establishing data sessions. We are continuing to monitor for service stability. We will provide another update in 2 hours or sooner once more information becomes available.
Posted Sep 18, 2020 - 13:34 PDT
Investigating
We are experiencing Super SIM connectivity issues. Our engineering team is actively working to restore the impacted service. We will provide another update in 1 hour or sooner once more information becomes available.
Posted Sep 18, 2020 - 12:37 PDT
This incident affected: INTERNET OF THINGS (Super SIM).