We are no longer experiencing SMS delivery delays from a subset of Twilio Long Codes to Altice network subscribers in the United States. This incident has been resolved.
Posted Mar 02, 2026 - 21:55 PST
Monitoring
We are observing recovery in SMS delivery delays from a subset of Twilio Long Codes to Altice network subscribers in the United States. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 02, 2026 - 20:06 PST
Update
Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Long Codes to Altice network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 8 hours or as soon as more information becomes available.
Posted Mar 02, 2026 - 20:02 PST
Update
Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Long Codes to Altice network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Mar 02, 2026 - 16:02 PST
Update
Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Long Codes to Altice network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 02, 2026 - 14:02 PST
Investigating
Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Long Codes to Altice network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 02, 2026 - 13:02 PST
This incident affected: CARRIER NETWORK (MMS Long Code, North America).