Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Devices using Super SIM may experience connectivity issues
Incident Report for Twilio
Resolved
The incident affecting Super SIM connectivity has been resolved, and the service is functioning normally at this time.
Posted Sep 05, 2020 - 15:53 PDT
Update
Service has been restored and we are continuing to monitor for additional problems related to the Super SIM connectivity issue.
Posted Sep 05, 2020 - 15:09 PDT
Monitoring
A fix has been implemented for this issue that is causing connectivity problems with our Super SIM product, and we are monitoring results. We expect to provide another update in 2 hours or sooner once more information becomes available.
Posted Sep 05, 2020 - 13:17 PDT
Update
We are experiencing Super SIM connectivity issues globally. Our engineering team is actively working with the affected network provider to resolve the issue. We will provide another update in 1 hour or sooner once more information becomes available.
Posted Sep 05, 2020 - 12:13 PDT
Update
We are continuing to investigate this issue.
Posted Sep 05, 2020 - 12:07 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 05, 2020 - 12:03 PDT
This incident affected: INTERNET OF THINGS (Super SIM).