Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Carriers around the world are experiencing capacity issues because of increased demand on their networks due to COVID-19. This may result in voice quality issues, busy signals, or other errors on your phone calls. Twilio continues to monitor the health of the global carrier networks and we are publishing the most up-to-date information on our Worldwide Telephony Network Congestion page.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound SMS failures to Azerbaijan Azercell Telecom BM network
Incident Report for Twilio
Resolved
Azerbaijan SMS issues are recovered and stable now. This incident is now resolved.
Posted Mar 17, 2020 - 09:18 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as the information becomes available.
Posted Mar 17, 2020 - 08:23 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as the information becomes available.
Posted Mar 17, 2020 - 04:31 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as the information becomes available.
Posted Mar 17, 2020 - 02:30 PDT
Investigating
We're currently observing non-deliveries for outbound messages submitted to handsets belonging to the Azercell Telecom BM network network in Azerbaijan. Our engineers are working with carrier partner to resolve this issue. We will provide further updates once the information becomes available.
Posted Mar 17, 2020 - 01:18 PDT
This incident affected: CARRIER NETWORK (SMS, Europe).