Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS/MMS Delivery Delays and Delivery Report Delays to Multiple US and Canada Networks from Twilio Toll Free Numbers
Incident Report for Twilio
Resolved
We are no longer experiencing SMS/MMS delivery delays and delivery report delays to multiple US and Canada networks when sending multi-segment messages from Twilio toll-free numbers. This incident has been resolved.
Posted Sep 10, 2021 - 17:11 PDT
Monitoring
We are observing recovery in SMS/MMS delivery delays and delivery report delays to multiple US and Canada networks when sending multi-segment messages from Twilio toll-free numbers We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 10, 2021 - 15:16 PDT
Update
We are continuing to work with our carrier partner to resolve the issue of SMS/MMS delivery delays and delivery report delays to multiple US and Canada networks when sending multi-segment messages from Twilio toll-free numbers. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Sep 10, 2021 - 14:06 PDT
Update
We are continuing to work with our carrier partner to resolve the issue of SMS/MMS delivery delays and delivery report delays to multiple US and Canada networks when sending from Twilio toll-free numbers. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Sep 10, 2021 - 13:00 PDT
Update
We are continuing to work with our carrier partner to resolve the issue of SMS/MMS delivery report delays to multiple US and Canada networks when sending from Twilio toll-free numbers. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Sep 10, 2021 - 11:01 PDT
Update
We are continuing our investigation and have discovered the SMS/MMS delivery report delays are to multiple US and Canada networks when sending from Twilio toll-free numbers. Actual delivery of messages is not affected. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 10, 2021 - 09:00 PDT
Update
We are experiencing delays in receiving message delivery reports when sending to multiple US networks on Twilio long codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 60 minutes or as soon as more information becomes available.
Posted Sep 10, 2021 - 08:00 PDT
Investigating
Our monitoring systems have detected a potential issue with SMS/MMS delivery report delays when sending to multiple US networks. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 10, 2021 - 07:52 PDT
This incident affected: CARRIER NETWORK (SMS Delivery Notifications & Status Callbacks).