The issue related to Super SIM failures has been resolved and is operating normally at this time.
Posted Jul 31, 2024 - 14:47 PDT
Monitoring
Between ~10:20 UTC and 14:20 UTC, connectivity on one of Super SIM's downstream connectivity partners was impacted. We observed ~26% decline in the number of devices connecting via the IMSI corresponding to those impacted partner. During this period, we observed an increase in the number of connections on other Super SIM IMSIs indicating that many devices reconnecting after the Super SIMs failed over to the other IMSIs on the SIM, reducing the overall impact. If you still have devices offline, try resetting the SIM's connectivity from the Twilio Console or restarting your device. We will provide an update in 2 hours, or as more information becomes available.
Posted Jul 31, 2024 - 13:01 PDT
Update
We continue experiencing Super SIM connectivity issues. Our engineering team is actively working with the affected network provider to resolve the issue. We will provide another update in 2 hours or sooner once more information becomes available.
Posted Jul 31, 2024 - 11:01 PDT
Update
Since 10:20AM UTC we are experiencing Super SIM connectivity issues. Our engineering team is actively working with the affected network provider to resolve the issue. We will provide another update in 2 hours or sooner once more information becomes available.
Posted Jul 31, 2024 - 09:01 PDT
Investigating
Our monitoring systems have detected a potential issue with Super SIM. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.