We are no longer experiencing SMS delivery delays when sending messages to Ditto network in Philippines over a subset of International pre registered Sender ID. This incident has been resolved.
Posted Feb 01, 2025 - 02:13 PST
Update
We continue to experience SMS delivery delays when sending messages to the Ditto network in the Philippines over a subset of international pre-registered sender IDs. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 01, 2025 - 00:38 PST
Investigating
We are experiencing SMS delivery delays when sending messages to Ditto network in Philippines over a subset of International pre registered Sender ID. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 31, 2025 - 23:37 PST
This incident affected: CARRIER NETWORK (SMS, APAC).