Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Issues with Billing Processing Delays
      Incident Report for Twilio
      Resolved
      Our engineering team has taken steps to mitigate the impact on payment processing delays, as well as recording and transcription billing delays. We are continuing to work with customers that were impacted by the incident to ensure the account balance is accurately reflected. This incident is resolved.
      Posted Dec 04, 2020 - 11:18 PST
      Monitoring
      Our engineering team has taken steps to mitigate the impact on payment processing delays. We have observed successful payment processing for the past 20 minutes. We are working with customers that were impacted by the incident to ensure the account balance is accurately reflected while continuing to monitor the system for stability. We will provide another update in 30 minutes or as soon as we have more information.
      Posted Dec 04, 2020 - 10:49 PST
      Update
      We are no longer seeing delays with recordings, but are still investigating an issue with Twilio billing. Customers may experience billing delays in the processing of payments. Our engineering team is actively working on the issue. We will provide another update in 1 hour or as soon as we have more information.
      Posted Dec 04, 2020 - 10:17 PST
      Update
      We are investigating an issue with Twilio billing. Customers may experience billing delays with recordings and transcriptions, as well as delays in the processing of payments. Our engineering team is actively working on the issue. We will provide another update in 1 hour or as soon as we have more information.
      Posted Dec 04, 2020 - 10:03 PST
      Update
      We are investigating an issue with the Billing API. Customers may experience billing delays with recordings and transcriptions. Our engineering team is actively working on the issue. We will provide another update in 1 hour or as soon as we have more information.
      Posted Dec 04, 2020 - 09:32 PST
      Investigating
      Our monitoring systems have detected a potential issue involving the Billing API, causing delays with recordings and transcriptions. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Dec 04, 2020 - 08:43 PST
      This incident affected: TWILIO PLATFORM (Billing).