Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
U.S. Shortcode MMS Delays
Incident Report for Twilio
Resolved
We are no longer experiencing MMS delays from US short codes to T-Mobile, Sprint, Verizon, or AT&T. This incident has been resolved.
Posted Sep 19, 2020 - 07:59 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
Posted Sep 19, 2020 - 06:31 PDT
Update
We are finding no more MMS delays from US short codes to T-Mobile, Sprint and Verizon but we are still experiencing the same delays in AT&T network. Our engineers are continuously working with our carrier partner to resolve the issue. We will provide more information in 8 hours or as soon as more information becomes available
Posted Sep 18, 2020 - 22:34 PDT
Update
MMS delays from US short codes to T-Mobile and Sprint continue to happen, and we are now experiencing delays to Verizon and AT&T. Our engineers continue working with our carrier partner to resolve the issue. We will provide more information in 4 hours or as soon as more information becomes available
Posted Sep 18, 2020 - 18:34 PDT
Update
MMS delays from US short codes to T-Mobile and Sprint continue, and we are now experiencing delays to Verizon and AT&T. Our engineers continue working with our carrier partner to resolve the issue. We will provide more information in 2 hours or as soon as more information becomes available.
Posted Sep 18, 2020 - 16:34 PDT
Investigating
We are again seeing a subset of US shortcodes experiencing MMS delivery delays to T-Mobile and Sprint. Our engineers are working with our carrier partner to resolve the issue. We will provide more information in 1 hour or as soon as more information becomes available.
Posted Sep 18, 2020 - 14:34 PDT
Monitoring
We are no longer seeing MMS delays from US shortcodes. We will continue to monitor the situation and provide an update in 2 hours or as soon as more information becomes available.
Posted Sep 18, 2020 - 13:52 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 18, 2020 - 11:54 PDT
Update
A portion of US shortcodes are seeing delays to carriers on MMS. Our engineers are working with our carrier partner to resolve the issue. We will provide more information in 1 hour or as soon as more information becomes available.
Posted Sep 18, 2020 - 10:55 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 18, 2020 - 10:44 PDT
This incident affected: CARRIER NETWORK (MMS Short Code, North America).