Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        Unable to Upgrade Twilio Accounts From Trial

        Incident Report for Twilio

        Resolved

        Our Engineers have investigated and found that there was no widespread issue but there were a couple of isolated cases. This incident is resolved.
        Posted Nov 04, 2025 - 04:40 PST

        Investigating

        We are experiencing an issue with Upgrading Twilio accounts from Trial on Twilio platform. Our Engineers are investigating. We will provide another update in 1 hour or as soon as more information becomes available.
        Posted Nov 04, 2025 - 03:30 PST
        This incident affected: TWILIO PLATFORM (Billing).