Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound SMS Delivery Delays to Subset of US and UK Short Codes
Incident Report for Twilio
Resolved
We experienced inbound SMS delivery delays to a subset of US and UK Short codes for 55 minutes, between 4:06 PM and 5:01 PM Pacific Time on 02/22/2021. During this period, customers may have experienced delays in receiving Inbound SMS to their US and UK Short Codes. The issue has now been resolved.
Posted Feb 22, 2021 - 17:50 PST
Update
We are experiencing inbound SMS delivery delays to a subset of US Short Codes. We are working with our carrier partners to resolve this issue. We expect to provide another update in 60 minutes or as soon as more information becomes available.
Posted Feb 22, 2021 - 17:33 PST
Investigating
Our monitoring systems have detected a potential issue with Inbound SMS Delivery Failures to a subset of US Short Codes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Feb 22, 2021 - 17:15 PST
This incident affected: CARRIER NETWORK (SMS Short Code, North America).