Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delays in sending messages for US Toll Free numbers
Incident Report for Twilio
Resolved
We have confirmed that delays with our toll free messaging provider sending messages to multiple US networks is now resolved.
Posted 6 months ago. Nov 05, 2018 - 11:01 PST
Update
We are no longer observing delays with our toll free messaging provider sending messages to multiple US networks. We are continuing to monitor.
Posted 6 months ago. Nov 05, 2018 - 10:31 PST
Identified
Our toll free messaging provider is experiencing delays in sending messages to multiple US networks. Our provider continues to troubleshoot the issues but we are currently experiencing messages delays of 1+ min for each message to all operators.
Posted 6 months ago. Nov 05, 2018 - 10:12 PST
This incident affected: PROGRAMMABLE MESSAGING (SMS).