Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Price for Twilio Calls missing
Incident Report for Twilio
Resolved
We have fully investigated the issues with a subset of Twilio Voice Calls missing billing information, and it was determined that the impact was limited to a small set of customers, who have been reached out individually to address any concerns. All systems are operational.
Posted Oct 08, 2020 - 19:24 PDT
Update
Our engineering team are continuing to investigate this issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Oct 08, 2020 - 18:51 PDT
Update
We are currently observing issues with a subset of Twilio Voice Calls missing billing information. Our engineering team has been alerted and is actively investigating. We expect to provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 08, 2020 - 17:53 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Oct 08, 2020 - 17:25 PDT
This incident affected: TWILIO PLATFORM (Billing).