Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to the UAE From a Subset of Domestic Pre-Registered Sender IDs
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays to the UAE from a subset of domestic pre-registered sender IDs. This incident has been resolved.
      Posted Aug 03, 2022 - 11:04 PDT
      Update
      We continue observing recovery in SMS delivery to the UAE from a subset of domestic pre-registered sender IDs. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 03, 2022 - 08:30 PDT
      Monitoring
      We are observing recovery in SMS delivery to the UAE from a subset of domestic pre-registered sender IDs. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 03, 2022 - 06:40 PDT
      Investigating
      We are experiencing SMS delivery delays to the UAE From a Subset of Domestic Pre-Registered Sender IDs. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Aug 03, 2022 - 05:44 PDT
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).