Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Degradation to Etisalat UAE
Incident Report for Twilio
Resolved
We are no longer experiencing delivery degradation when sending SMS to Etisalat UAE. This incident has been resolved.
Posted Sep 10, 2020 - 01:55 PDT
Monitoring
We are observing improvements in SMS delivery to Etisalat Telecom in UAE. Our engineers are working with our carrier partner to resolve the issue. We will provide an update in the next 2 hours with additional information.
Posted Sep 09, 2020 - 23:56 PDT
Investigating
Our monitoring systems have detected a potential issue in SMS delivery to Etisalat Telecom in UAE. Our engineers are working with our carrier partner to resolve the issue. We will provide an update in the next 1 hour with additional information.
Posted Sep 09, 2020 - 22:58 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).