Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Elevated message delivery to Mobinil handsets in Egypt
Incident Report for Twilio
Resolved
All services are operating normally.
Posted 7 months ago. Jul 17, 2018 - 20:01 PDT
Monitoring
We are seeing recovery of the problem. Our engineering team will continue to monitor the situation. We will post another update in 30 minutes
Posted 7 months ago. Jul 17, 2018 - 19:27 PDT
Update
We are continuing to investigate this issue with our carrier partners. We will provide another update in 1 hour.
Posted 7 months ago. Jul 17, 2018 - 18:41 PDT
Investigating
We are currently investigating message delivery failures to Mobinil handsets in Egypt. Our engineers are working with our carrier partner to restore service. We will provide an update as quickly as possible.
Posted 7 months ago. Jul 17, 2018 - 18:03 PDT
This incident affected: PROGRAMMABLE MESSAGING (SMS).