We are no longer experiencing delivery report delays when sending messages to multiple networks in the US from a subset of short codes. This incident has been resolved.
Posted Nov 04, 2025 - 16:09 PST
Monitoring
We are observing recovery in MMS delivery report delays when sending messages to multiple networks in the US from a subset of short codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 04, 2025 - 14:09 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 04, 2025 - 10:08 PST
Update
We have identified that this incident is only impacting Delivery Reports, we can confirm that MMS delivery is not impacted, Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.
Posted Nov 04, 2025 - 10:07 PST
Update
We continue experiencing MMS delivery delays to Verizon Wireless Network In United States of America (311-489) via a Subset of Twilio numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
Posted Nov 04, 2025 - 02:39 PST
Update
We continue experiencing MMS Delivery Delays To Verizon Wireless Network In United States of America (311-489) Via A Subset of Twilio Numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Nov 03, 2025 - 22:45 PST
Update
We are experiencing MMS Delivery Delays To Verizon Wireless Network In United States of America (311-489) Via A Subset of Twilio Numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 03, 2025 - 20:50 PST
Investigating
We are experiencing MMS Delivery Delays To Verizon Wireless Network In United States of America (311-489) Via A Subset of Twilio Numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 03, 2025 - 19:57 PST
This incident affected: CARRIER NETWORK (MMS Long Code, North America).