Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Delays in US Over a Small Subset of Shortcodes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing MMS delivery delays to US over a small subset of shortcodes. This incident has been resolved.
      Posted Aug 08, 2022 - 21:37 PDT
      Update
      We continue to observe recovery in MMS delivery delays when sending US messages over a small subset of shortcodes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 08, 2022 - 19:42 PDT
      Update
      We continue to observe recovery in MMS delivery delays when sending US messages over a small subset of shortcodes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 08, 2022 - 17:48 PDT
      Monitoring
      We are observing recovery in MMS delivery delays when sending US messages over a small subset of shortcodes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 08, 2022 - 15:44 PDT
      Update
      We are continuing to investigate MMS delivery delays over US phone numbers for a small subset of shortcodes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hour or as soon as more information becomes available.
      Posted Aug 08, 2022 - 13:55 PDT
      Investigating
      We are experiencing MMS delivery delays to US over a small subset of shortcodes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Aug 08, 2022 - 12:53 PDT
      This incident affected: CARRIER NETWORK (MMS Short Code, North America).