Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Short code MMS delays to US networks
Incident Report for Twilio
Resolved
Short code MMS is now working as designed.
Posted 6 months ago. Dec 25, 2018 - 13:11 PST
Update
We continue to work with our partners on MMS delays to US networks, primarily Sprint.
Posted 6 months ago. Dec 25, 2018 - 12:26 PST
Update
We are continuing to work with our partners on MMS delays to US networks, primarily Sprint.
Posted 6 months ago. Dec 25, 2018 - 10:24 PST
Investigating
We have detected an issue with short code MMS delays to US networks, primarily Sprint. We will continue to investigate and work with our partners.
Posted 6 months ago. Dec 25, 2018 - 09:22 PST
This incident affected: PROGRAMMABLE MESSAGING (MMS).