Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      On Call Engineers are Investigating
      Incident Report for Twilio
      Resolved
      We have fully investigated the issue when customers initiated a call to get verified, and it was determined that it is related to the ongoing incident https://status.twilio.com/incidents/w7gx28wwpptn
      Posted Jul 26, 2022 - 15:26 PDT
      Investigating
      Our monitoring systems have detected a potential issue when customers initiate a call for their Verification. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jul 26, 2022 - 14:59 PDT