Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delays in Super SIM Usage Reporting
      Incident Report for Twilio
      Resolved
      We have addressed the issue causing the delays in processing Super SIM usage records.
      Posted May 10, 2022 - 16:51 PDT
      Monitoring
      Our engineers replaced a faulty host causing the delays in processing Super SIM usage records. Usage records are again being processed and reported timely. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
      Posted May 10, 2022 - 16:20 PDT
      Update
      Our engineering team is continuing to investigate the source of the processing lag. We estimate that the current time from when a Super SIM usage record is generated and when it's processed to be approximately 6 mins. We are actively working to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted May 10, 2022 - 15:56 PDT
      Update
      Our engineering team is continuing to investigate the source of the processing lag. We estimate that the current time from when a Super SIM usage record is generated and when it's processed to be approximately 6 mins. We are actively working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 10, 2022 - 13:57 PDT
      Update
      Our engineering team is investigating an increase in the number of Super SIM usage events to be processed by our aggregation and reporting system that powers Super SIM's Usage Records. This backlog of events may result in delays in usage incurred by SIMs being reported from our /UsageRecords API and in Console. Our team is investigating the root cause and potential impact. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted May 10, 2022 - 13:01 PDT
      Investigating
      Our monitoring systems have detected a potential issue with Super SIM usage reporting. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted May 10, 2022 - 12:40 PDT
      This incident affected: INTERNET OF THINGS (Super SIM).