Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Issue with Twilio Billing Processing Causing Account Suspension and Balance Update Reflection for a Subset of Customers
Incident Report for Twilio
Resolved
Billing processing issue that was causing account balance update delays and account suspensions for a subset of customers has been resolved and the billing API and console are operating normally at this time.
Posted Apr 20, 2021 - 00:11 PDT
Monitoring
We have addressed the billing processing issue that was causing account balance update delays and account suspensions for a subset of customers. Account balance should now accurately reflect the successful payment made earlier. Error rate has significantly subsided since the fix, and we are monitoring the service for 2 hours to ensure a full recovery.
Posted Apr 19, 2021 - 22:12 PDT
Update
We continue to experience a billing processing issue that causes delays in account balance reflection for a subset of customers on credit card payments. We've temporarily resolved the account suspension issue so you can continue using the account with a negative balance. We are actively working on resolving the issue and will provide another update in 4 hours or as soon as more information becomes available.
Posted Apr 19, 2021 - 19:31 PDT
Update
We continue to experience a billing processing issue that causes delays in account balance reflection for a subset of customers on credit card payments. We've temporarily resolved the account suspension issue so you can continue using the account with a negative balance. We are actively working on resolving the issue and will provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 19, 2021 - 17:31 PDT
Update
We continue to experience a billing processing issue that causes delays in account balance reflection and could result in account suspension for a subset of customers on credit card payments. Please do not retry payment as the balance is not updating or reflecting successful payments at this time. Please reach out to Twilio support if your account is suspended and our team will assist you immediately. We are actively working on resolving the issue and will provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 19, 2021 - 15:23 PDT
Update
We continue to experience a billing processing issue that causes delays in account balance reflection and could result in account suspension for a subset of customers on credit card payments. Please do not retry payment as the balance is not updating or reflecting successful payments at this time. Please reach out to Twilio support if your account is suspended and our team will assist you immediately. We are actively working on resolving the issue and will provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 19, 2021 - 13:23 PDT
Update
We continue to investigate an issue with billing processing and balance update reflection causing account suspension for a subset of customers. Until the issue is resolved, please do not retry payment as the balance is not updating or reflecting successful payments. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 19, 2021 - 11:31 PDT
Investigating
We are investigating an issue with Billing Processing and Balance Update Reflection Causing Account Suspension for a Subset of Customers. Until the issue is resolved, please do not retry payment as the balance is not updating or reflecting successful payments. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 19, 2021 - 10:42 PDT
This incident affected: TWILIO PLATFORM (Billing).