Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Calls failing to Kenya phone numbers
Incident Report for Twilio
Resolved
All services are operating normally.
Posted 10 months ago. Sep 10, 2018 - 01:16 PDT
Investigating
We have detected an increase in call failures for calls to some Twilio phone numbers in Kenya due to a carrier fault. We have escalated the issue with the carrier and will provide more information as it becomes available.
Posted 10 months ago. Sep 09, 2018 - 13:39 PDT
This incident affected: PROGRAMMABLE VOICE (PSTN).