Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Canada On Short Code and Long Code Numbers
Incident Report for Twilio
Resolved
We have confirmed that we are no longer experiencing delays in sending and receiving SMS to Canada on both short codes and long codes.
Posted 3 months ago. Feb 14, 2019 - 17:26 PST
Investigating
We have detected delays in inbound and outbound SMS delivery on both short codes and long codes to some parts of Canada. We are working with our provider to resolve this issue. We will provide more information when available.
Posted 3 months ago. Feb 14, 2019 - 15:53 PST
This incident affected: CARRIER NETWORK (SMS Long Code, North America, SMS Short Code, North America).