Status
Welcome to the Twilio status page. Here you will find real-time information about status of our services.
SMS Delivery issue to Kenya Safaricom
Incident Report for Twilio
Resolved
We have confirmed that SMS Delivery to Kenya Safaricom is operating normally at this time.
Posted 5 months ago. Jun 21, 2018 - 07:02 PDT
Investigating
We are experiencing SMS delivery failures to Kenya Safaricom. We are working with our carrier partner to resolve the issue. Next update in 1 hour.
Posted 5 months ago. Jun 21, 2018 - 06:10 PDT
This incident affected: Programmable SMS (SMS).