Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      On Call Engineers are Investigating an issue with Twilio Console Active Numbers Page Messaging Service Value
      Incident Report for Twilio
      Resolved
      The Twilio Console issue of modification to a Twilio phone number's Friendly name causing the removal of the phone number’s configurations has been resolved and is operating normally at this time.
      Posted Mar 30, 2023 - 12:58 PDT
      Investigating
      We have detected a potential issue where using the Twilio Console to modify a Twilio phone number’s Friendly name causes the removal of the phone number’s configurations. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Mar 30, 2023 - 12:09 PDT