We are no longer experiencing high latency with AWS. The incident has been resolved.
Posted Aug 02, 2024 - 14:10 PDT
Update
We are observing recovery on the high latency with AWS. We will continue to monitor for system stability. We'll provide another update in 4 hours or as soon as more information becomes available.
Posted Aug 02, 2024 - 12:17 PDT
Monitoring
We are observing recovery on the high latency with AWS. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Aug 02, 2024 - 10:17 PDT
Update
We are investigating high latency with AWS which may result in timeouts with Twilio APIs. We expect to provide an update in 1 hour or as soon as more information becomes available.
Posted Aug 02, 2024 - 09:02 PDT
Investigating
We are investigating high latency with AWS which may result in timeouts with Twilio APIs. We expect to provide an update in 1 hour or as soon as more information becomes available.
Posted Aug 02, 2024 - 08:20 PDT
This incident affected: DEVELOPER TOOLS (REST API).