Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Report Delays Over a Subset of US Short Codes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing MMS Delivery Report Delays over a subset of US Short Codes. This incident has been resolved.
      Posted Sep 10, 2022 - 05:00 PDT
      Update
      We are observing recovery in MMS Delivery Report Delays over a subset of US Short Codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 30 mins or as soon as more information becomes available.
      Posted Sep 10, 2022 - 04:34 PDT
      Monitoring
      We are observing recovery in MMS Delivery Report Delays over a subset of US Short Codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 10, 2022 - 02:43 PDT
      Update
      We are continuing to experience MMS Delivery Report Delays over a subset of US Short Codes. Our engineering team has been alerted and is actively investigating. We will update in 2 hours or as soon as we have more information.
      Posted Sep 10, 2022 - 00:52 PDT
      Investigating
      We are continuing to experience MMS Delivery Report Delays over a subset of US Short Codes. Our engineering team has been alerted and is actively investigating. We will update in 1 hour or as soon as we have more information.
      Posted Sep 09, 2022 - 23:58 PDT
      Monitoring
      We are observing recovery in MMS Delivery Report Delays over a subset of US Short Codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 09, 2022 - 21:59 PDT
      Update
      We still continue to experience MMS Delivery Report Delays over a subset of US Short Codes. Our engineering team has been alerted and is actively investigating. We will update in 8 hours or as soon as we have more information.
      Posted Sep 09, 2022 - 19:04 PDT
      Update
      We are continuing to experience MMS Delivery Report Delays over a subset of US Short Codes. Our engineering team has been alerted and is actively investigating. We will update in 4 hours or as soon as we have more information.
      Posted Sep 09, 2022 - 15:20 PDT
      Update
      We are continuing to experience MMS Delivery Report Delays over a subset of US Short Codes. Our engineering team has been alerted and is actively investigating. We will update in 2 hours or as soon as we have more information.
      Posted Sep 09, 2022 - 13:29 PDT
      Update
      Our monitoring systems have detected a potential issue with MMS Delivery Report Delays over a subset of US Short Codes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Sep 09, 2022 - 12:36 PDT
      Investigating
      Our monitoring systems have detected a potential issue with MMS Delivery Report Delays over a subset of US Short Codes. Our engineering team has been alerted and is actively investigating. We will update in 1 hour or as soon as we have more information.
      Posted Sep 09, 2022 - 12:27 PDT
      This incident affected: CARRIER NETWORK (MMS Short Code, North America).