Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Asiacell in Iraq
Incident Report for Twilio
Resolved
The issue is now resolved and the service is back to normal delivery.
Posted May 11, 2020 - 14:47 PDT
Update
We are still experiencing SMS delivery delays when sending messages to Asiacell network. Our engineers continue to work with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted May 11, 2020 - 10:24 PDT
Update
We are still experiencing SMS delivery delays when sending messages to Asiacell network. Our engineers continue to work with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted May 11, 2020 - 06:12 PDT
Update
We are continuing to investigate this issue.
Posted May 11, 2020 - 01:10 PDT
Update
We are continuing to investigate this issue.
Posted May 10, 2020 - 21:09 PDT
Update
We are continuing to investigate this issue.
Posted May 10, 2020 - 19:21 PDT
Investigating
We are experiencing SMS delivery delays when sending messages to the Asiacell network. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted May 10, 2020 - 18:11 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).