Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Additional Prefix to callerID for a Percentage of Canadian Numbers
Incident Report for Twilio
Resolved
All systems are operating normally.
Posted 9 months ago. Apr 13, 2018 - 11:02 PDT
Investigating
We are experiencing an issue affecting callerID to a percentage of Canadian land line phone numbers. Affected landline calls have an extra +51 or +54 prefix prepended to the callerID. We are working with our carrier partners to resolve this issue. Next update within two hours.
Posted 9 months ago. Apr 13, 2018 - 10:10 PDT
This incident affected: PROGRAMMABLE VOICE (PSTN).