Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 01, 2025 - 06:00 PDT
Update
This planned maintenance has been cancelled, and a new date has not yet been determined. We will provide an update once the maintenance has been rescheduled. Thank you!
=========================== Twilio will conduct a planned maintenance on our circuits in the Australia Twilio network from 01 August 2025 at 06:00 PDT until 01 August 2025 at 08:00 PDT. During the maintenance window there could be intermittent impact on Interconnect services via the Twilio’s network in Australia.
Posted Jul 31, 2025 - 20:36 PDT
Scheduled
Twilio will conduct a planned maintenance on our circuits in the Australia Twilio network from 01 August 2025 at 06:00 PDT until 01 August 2025 at 08:00 PDT. During the maintenance window there could be intermittent impact on Interconnect services via the Twilio’s network in Australia.
Posted Jun 24, 2025 - 20:18 PDT
This scheduled maintenance affected: INTERCONNECT.