Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Delays to US Phone Numbers From a Subset of Short Codes
Incident Report for Twilio
Resolved
We are no longer experiencing MMS delivery delays when sending messages to US Phone Numbers from the Subset of Short codes that was having the issue. This incident has been resolved.
Posted Jun 02, 2021 - 15:26 PDT
Monitoring
We are observing recovery in MMS delivery delays when sending messages to US phone numbers from a subset of short codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 02, 2021 - 13:14 PDT
Update
We are experiencing MMS delivery delays to US phone numbers for a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Jun 02, 2021 - 12:20 PDT
Investigating
Our monitoring systems have detected a potential issue with MMS Delivery Delays to US Phone Numbers from a Subset of Shortcodes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jun 02, 2021 - 12:10 PDT
This incident affected: CARRIER NETWORK (MMS Long Code, North America, MMS Short Code, North America).