Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound delivery delays and failures towards Egypt (Vodafone)
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Feb 09, 2020 - 15:29 PST
Monitoring
We are observing recovery for messages in Egypt. We will continue to monitor the status and provide an update in 30 minutes.
Posted Feb 09, 2020 - 15:05 PST
Update
We are continuing to investigate this issue.
Posted Feb 09, 2020 - 12:32 PST
Update
We are continuing to investigate this issue.
Posted Feb 09, 2020 - 10:30 PST
Investigating
We are experiencing SMS delivery delays and failures to Egypt. We are working with our carrier partners to resolve this issue. We will provide further updates as soon as they become available.
Posted Feb 09, 2020 - 09:33 PST
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).