Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Delays Over Toll-Free Numbers to United States Verizon
      Incident Report for Twilio
      Resolved
      We are no longer experiencing MMS delivery delays over Toll-free numbers to United States Verizon. This incident has been resolved.
      Posted Jun 24, 2022 - 17:50 PDT
      Monitoring
      We are observing recovery in MMS delivery delays over Toll-free numbers to United States Verizon. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 24, 2022 - 15:51 PDT
      Update
      We are experiencing MMS delivery delays over Toll-free numbers to United States Verizon. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 24, 2022 - 13:50 PDT
      Investigating
      We are experiencing MMS delivery delays over Toll-free numbers to United States Verizon. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jun 24, 2022 - 12:54 PDT
      This incident affected: CARRIER NETWORK (MMS Toll-Free, North America).