Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS and SMS Delivery Delays to US Verizon Network (311-489) From Toll-Free Numbers and a Subset of Short Codes
Incident Report for Twilio
Resolved
We are no longer experiencing MMS and SMS delivery delays when sending messages to US Verizon Network from toll-free numbers and a subset of short codes. This incident has been resolved.
Posted Jun 09, 2021 - 16:57 PDT
Monitoring
We are observing recovery in MMS and SMS delivery delays when sending messages to US Verizon Network over a subset of short codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 09, 2021 - 15:04 PDT
Update
We are no longer experiencing MMS and SMS delivery delays when sending messages to US Verizon Network from toll-free numbers.

We are continuing to experience MMS and SMS delivery delays when sending messages to US Verizon Network over a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Jun 09, 2021 - 12:20 PDT
Update
We are experiencing MMS and SMS delivery delays when sending messages to US Verizon Network (311-489) from toll-free numbers and a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 09, 2021 - 10:23 PDT
Update
We are continuing to experience SMS delivery delays when sending messages to US Verizon Network (311-489) from toll-free numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 09, 2021 - 09:17 PDT
Investigating
We are experiencing SMS delivery delays when sending messages to US Verizon Network (311-489) from a Subset of Toll-Free Numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jun 09, 2021 - 08:18 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America, MMS Short Code, North America, SMS Toll-Free, North America, MMS Toll-Free).