Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delay and Failure to Telma Madagascar
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delay and failure when sending messages to Telma Madagascar. This incident has been resolved.
      Posted Nov 23, 2022 - 05:30 PST
      Monitoring
      We are observing recovery in SMS delivery delay and successful SMS delivery when sending messages to Telma Madagascar. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 23, 2022 - 03:47 PST
      Update
      We continue experiencing SMS delivery delay and failure when sending messages to Telma Madagascar. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Nov 23, 2022 - 00:01 PST
      Update
      We continue experiencing SMS delivery delay and failure when sending messages to Telma Madagascar. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 22, 2022 - 22:01 PST
      Investigating
      We are experiencing SMS delivery delay and failure sending to Telma Madagascar. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Nov 22, 2022 - 21:01 PST
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).