Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Failures on a Subset of US Short Codes to Cellular One
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Nov 10, 2020 - 19:50 PST
Update
We are no longer experiencing delivery delays to Cellular One from a subset of Twilio Short Codes. This incident has been resolved.
Posted Nov 10, 2020 - 19:39 PST
Monitoring
We are observing recovery of SMS delivery failures to Cellular One from a subset of Twilio Short Codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available
Posted Nov 10, 2020 - 18:20 PST
Investigating
We are experiencing SMS delivery failures to Cellular One from a subset of Twilio Short Codes. We are working with our carrier partners to resolve this issue. We expect to provide another update in 2 hours or as soon as more information becomes available
Posted Nov 10, 2020 - 16:20 PST
This incident affected: CARRIER NETWORK (SMS Short Code, North America).