Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery delays towards Glo Mobile Nigeria
Incident Report for Twilio
Resolved
The issue has been resolved and SMS delivery to Glo Nigeria is flowing normally now.
Posted Mar 23, 2020 - 06:30 PDT
Monitoring
We are observing successful and normal delivery for SMS to Glo network in Nigeria. We will continue to monitor to ensure a full recovery.
Posted Mar 23, 2020 - 05:53 PDT
Update
Our engineers are still working on this issue with the underlying carrier. we will provide more updates as soon as they become available.
Posted Mar 23, 2020 - 01:41 PDT
Investigating
We are observing message delivery delays for our SMS sent to Glo Mobile in Nigeria. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
Posted Mar 23, 2020 - 00:04 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).