Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS delivery delayed for Sprint in US
Incident Report for Twilio
Resolved
All services are operating normally.
Posted about 1 month ago. Mar 19, 2019 - 02:12 PDT
Monitoring
We have detected delays delivering SMS to Sprint in the US. The carrier has issued a notice that emergency maintenance may be ongoing through 08:00 UTC and may delay SMS both to and from the carrier during this time. We continue to monitor the situation.
Posted about 1 month ago. Mar 18, 2019 - 22:42 PDT