Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Super SIM Network Connectivity Issues
      Incident Report for Twilio
      Resolved
      The incident causing connectivity issues for Super SIMs has been resolved.
      Posted Jun 17, 2021 - 13:39 PDT
      Monitoring
      Our downstream network partner has completed their emergency maintenance window successfully. They will continue monitoring for service stability over the next 24 hours. We will provide a status update in 24 hours or as soon as more information becomes available.
      Posted Jun 17, 2021 - 08:54 PDT
      Update
      Our downstream network partner has completed their emergency maintenance window successfully. They continue monitoring for the next 12-24 hours. An additional maintenance window is planned for tomorrow around 06:00 UTC to repeat the procedure for another network connection to improve stability. We will provide a status update in 8 hours or as soon as more information becomes available.
      Posted Jun 17, 2021 - 05:32 PDT
      Update
      Our downstream network partner is in the middle of their emergency maintenance window. It is not expected that this work will interrupt traffic. We continue to work with them on this and we will provide a status update in 8 hours or as soon as more information becomes available.
      Posted Jun 16, 2021 - 23:31 PDT
      Update
      Our downstream network partner is in the middle of their emergency maintenance window. It is not expected that this work will interrupt traffic. We continue to work with them on this and we will provide a status update in 4 hours or as soon as more information becomes available.
      Posted Jun 16, 2021 - 19:30 PDT
      Update
      Our downstream network partner is in the middle of their emergency maintenance window. It is expected to complete within the next hour. It is not expected that this work will interrupt traffic. We will provide an update at 7:30 PM PT or as more information becomes available.
      Posted Jun 16, 2021 - 17:30 PDT
      Update
      Our downstream network partner believes they have identified an issue on one of their network connections that may have caused the drops that have occurred since 7:30am PT today. They are planning an emergency maintenance window which will begin at 3:30pm PT. It is not expected that this work will interrupt traffic. We will provide an update at 5:30 PM PT or as more information becomes available.
      Posted Jun 16, 2021 - 15:22 PDT
      Update
      After previously seeing traffic at 90% recovery, our monitoring shows that traffic is unstable, resulting in intermittent connectivity for our customers. We continue to investigate with our carrier partner and we will provide a status update in two hours or as soon as more information becomes available.
      Posted Jun 16, 2021 - 14:55 PDT
      Update
      After previously seeing traffic at 90% recovery, our monitoring shows that traffic is unstable, resulting in intermittent connectivity for our customers. We continue to investigate with our carrier partner and we will provide a status update in one hour or as soon as more information becomes available.
      Posted Jun 16, 2021 - 13:55 PDT
      Investigating
      After previously seeing traffic at 90% recovery, our monitoring shows that traffic is unstable, resulting in intermittent connectivity for our customers. We are reverting back to investigating with our carrier partner and we will provide a status update in 30 minutes or as soon as more information becomes available.
      Posted Jun 16, 2021 - 13:22 PDT
      Update
      We are seeing that the traffic between our partner carrier and Twilio is fully restored and our customers successfully re-attach. Our partner carrier has also moved to monitoring for 24 hours to investigate the root cause and is not planning any changes until tomorrow. Our customer traffic is at about 90% of the before incident levels and very slowly increasing further. We will provide another update in 24 hours or sooner once more information becomes available.
      Posted Jun 16, 2021 - 12:50 PDT
      Monitoring
      Our impacted downstream partners continue working on restoring links between themselves. User traffic is successfully reaching Twilio. We are now seeing new data sessions being established on 2G/3G and LTE. We are continuing to monitor the recovery as device reconnect and additional links are restored. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 16, 2021 - 10:50 PDT
      Update
      We experienced a temporary drop in data sessions on one of Super SIM's downstream connectivity partners around 7:30am PT. Devices that have reconnected to the cellular networks may have been able to reconnect. We have observed some devices that have reconnected after the drop that are still unable to use data. We are continuing to investigate this with our connectivity partners. We will provide another update in 2 hours or sooner once more information becomes available.
      Posted Jun 16, 2021 - 09:12 PDT
      Update
      We are experiencing Super SIM connectivity issues with one of our partners. Devices may experience data connectivity issues. Our engineering team is still actively working with the affected network provider to resolve the issue. We will provide another update in 1 hour or sooner once more information becomes available.
      Posted Jun 16, 2021 - 08:13 PDT
      Investigating
      We are experiencing Super SIM connectivity issues with one of our partners. Devices may experience data connectivity issues. Our engineering team is actively working with the affected network provider to resolve the issue. We will provide another update in 30 mins or sooner once more information becomes available.
      Posted Jun 16, 2021 - 07:44 PDT