Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Caller Name Lookups API Returning Blank Results for US Numbers
      Incident Report for Twilio
      Resolved
      Caller Name Lookups API Returning blank results for US Numbers has been resolved. The Caller Name Lookups API is operating normally at this time.
      Posted Jun 17, 2020 - 15:59 PDT
      Monitoring
      Our data partner has rolled out a fix to address the failures. We will continue to monitor to ensure a full recovery.
      Posted Jun 17, 2020 - 15:07 PDT
      Investigating
      We have seen a recurrence of failures in our Caller Name Lookup API resulting in blank responses affecting less than 1% of requests. We will provide further updates as more information becomes available from our data partners.
      Posted Jun 17, 2020 - 13:53 PDT
      Monitoring
      We are observing successful Caller Name API responses for the last hour. We will continue to monitor to ensure a full recovery.
      Posted Jun 17, 2020 - 11:58 PDT
      Update
      We have observed failures in our Caller Name Lookups API resulting in blank results being returned for a subset of customers. The impact is only isolated to the U.S. as this API is only supported there. We are working with our data partners and will provide further updates as more information becomes available.
      Posted Jun 17, 2020 - 10:24 PDT
      Investigating
      Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jun 17, 2020 - 09:38 PDT
      This incident affected: ACCOUNT SECURITY (Lookup).