Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to T-Mobile and Metro from Twilio Toll-Free Numbers
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery delays to T-Mobile and Metro by T-Mobile devices. This incident has been resolved.
      Posted Dec 03, 2020 - 17:43 PST
      Monitoring
      We are observing successful SMS delivery when sending from Twilio toll-free numbers to T-Mobile and Metro by T-Mobile devices for the past 1 hour. Our engineers will continue to monitor to ensure full service recovery. We expect to provide another update in 2 or as soon as more information becomes available.
      Posted Dec 03, 2020 - 15:55 PST
      Update
      We continue to experience SMS delivery delays when sending messages to T-Mobile and Metro from Twilio Toll-Free Numbers. Our engineers are working with our carrier partner urgently to resolve the issue, but do not have more details at this time. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Dec 03, 2020 - 13:08 PST
      Update
      We are still experiencing SMS delivery delays when sending messages to T-Mobile and Metro from Twilio Toll-Free Numbers. Our engineers are working with our carrier partner urgently to resolve the issue, but do not have more details at this time. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Dec 03, 2020 - 11:10 PST
      Update
      We are still experiencing SMS delivery delays when sending messages to T-Mobile and Metro from Twilio Toll-Free Numbers. Our engineers are working with our carrier partner to resolve the issue, but do not have more details at this time. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Dec 03, 2020 - 09:12 PST
      Update
      We are still experiencing SMS delivery delays when sending messages to T-Mobile and Metro from Twilio Toll-Free Numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Dec 03, 2020 - 08:01 PST
      Update
      We are still experiencing SMS delivery delays when sending messages to T-Mobile (310-800) and Metro(311-660). Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Dec 03, 2020 - 07:15 PST
      Investigating
      We are experiencing SMS delivery delays when sending messages to T-Mobile (310-800) and Metro(311-660). Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Dec 03, 2020 - 06:15 PST
      This incident affected: CARRIER NETWORK (SMS Toll-Free, North America).