The incident has been resolved and SMS delivery from a subset of Twilio Short Codes to Multiple Networks in the United States and Puerto Rico is operating normally.
Posted Mar 13, 2026 - 16:01 PDT
Update
We have observed a recovery in SMS delivery from a subset of Twilio Short Codes to Multiple Networks in the United States and Puerto Rico and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 13, 2026 - 14:36 PDT
Monitoring
We have observed a recovery in SMS delivery from a subset of Twilio Short Codes to Verizon, AT&T, and T-Mobile network subscribers in the United States and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 13, 2026 - 14:09 PDT
Update
Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Short Codes to Verizon, T-Mobile and AT&T network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 13, 2026 - 13:53 PDT
Identified
Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Short Codes to Verizon and T-Mobile network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 13, 2026 - 13:41 PDT
Investigating
Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Short Codes to Verizon network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 13, 2026 - 13:32 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America).