Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Super SIM Network Connectivity Issues
Incident Report for Twilio
Resolved
Super SIM network connectivity issues has been resolved and Super SIM is operating normally at this time.
Posted Oct 06, 2021 - 03:57 PDT
Update
The issue causing Super SIM connectivity drop has been identified. Our team is actively working to restore the service. We will provide another update in 4 hour or sooner once more information becomes available.
Posted Oct 06, 2021 - 02:35 PDT
Update
Super SIM data connectivity has been restored. As part of the investigations our team identified that usage information is not being reported for about 10% of the connected devices since 22:45 PT 10/06/2021. The team is working on restoring the service. We will provide another update in 2 hours or sooner once more information becomes available.
Posted Oct 06, 2021 - 00:35 PDT
Identified
The issue causing Super SIM connectivity drop has been identified. Our team is actively working to restore the service. We will provide another update in 1 hour or sooner once more information becomes available.
Posted Oct 06, 2021 - 00:10 PDT
Investigating
We are investigating an issue where devices using Super SIM may have experienced data connectivity drop. We are actively working to resolve the issue. We will provide another update in 1 hour or sooner once more information becomes available.
Posted Oct 05, 2021 - 23:14 PDT
This incident affected: INTERNET OF THINGS (Super SIM).