Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Carriers around the world are experiencing capacity issues because of increased demand on their networks due to COVID-19. This may result in voice quality issues, busy signals, or other errors on your phone calls. Twilio continues to monitor the health of the global carrier networks and we are publishing the most up-to-date information on our Worldwide Telephony Network Congestion page.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Canadian phone numbers are not reachable due to severe Voice Network congestion in Canada.
Incident Report for Twilio
Resolved
We have seen recovery of the Voice Network as peak workday time on Friday has passed. We expect this recovery will extend into the weekend.
Posted Mar 20, 2020 - 17:12 PDT
Identified
Twilio and other vendors have seen an extreme increase in Voice traffic in Canada which has caused Voice Networks to be severely saturated. The effect is large numbers of calls do not reach the Twilio network.
We are working with Intermediate and Local Carriers to understand and remediate these call issues.
Twilio will post additional information as it becomes available.
Posted Mar 20, 2020 - 12:34 PDT
This incident affected: CARRIER NETWORK (Voice, North America).